PikPok - Division 1 Flat Racing Live Issue – Incident details

All systems operational

Division 1 Flat Racing Live Issue

Resolved
Degraded performance
Started 6 months agoLasted about 1 hour

Affected

Rival Stars: Horse Racing

Degraded performance from 1:59 AM to 3:04 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are aware of an ongoing in-game error where players can enter Division 1 Flat Racing events but cannot complete the race.

    Our team is actively working to resolve the issue and get our players racing again.

    We apologize for any inconvenience this may have caused, and we appreciate your patience while we resolve the issue.